PocketMine Crash Archive

#29781728 Unknown error

Submitted by PocketMine-MP 1.6dev

General information

Version: 1.6dev
API version: 1.13.1
Caused by a Plugin: Not directly
Report date: Thursday 08/09/2022 21:43:05
Attached Issue: None

System Information

PHP version: 5.6.10
Operating system: linux
System banner: Linux 096923162c8a 5.15.0-41-generic #44-Ubuntu SMP Wed Jun 22 14:20:53 UTC 2022 x86_64

Error information

file_put_contents(/home/gs-40422/worlds/world/level.dat): failed to open stream: No such file or directory
File: /src/pocketmine/level/format/generic/BaseLevelProvider
Line: #125
Error level: warning

[116] 		return $this->levelData;
[117] 	}
[118] 
[119] 	public function saveLevelData(){
[120] 		$nbt = new NBT(NBT::BIG_ENDIAN);
[121] 		$nbt->setData(new Compound("", [
[122] 			"Data" => $this->levelData
[123] 		]));
[124] 		$buffer = $nbt->writeCompressed();
[125] 		file_put_contents($this->getPath() . "level.dat", $buffer);
[126] 	}
[127] 
[128] 
[129] }
[130] 
[131] 
[132] 
[133] 
[134] 
[135] 
#0 /src/pocketmine/level/format/generic/BaseLevelProvider(125): file_put_contents(string /home/gs-40422/worlds/world/level.dat, string [email protected]#......t..6..........?..M...;w.wr GVP..jKA.}`$.3.DC..Y').......L...;..}x....D...j..^.>zx....v.......PA......yIm\X.XK....}..$.}].Y....I.J..]a.w.N....X*..:..;.......}.Di......l/....V..._^.,..?..wp'...)
#1 /src/pocketmine/level/Level(1006): pocketmine\level\format\generic\BaseLevelProvider->saveLevelData(boolean)
#2 /src/pocketmine/Server(2367): pocketmine\level\Level->save(boolean )
#3 /src/pocketmine/Server(2511): pocketmine\Server->doAutoSave(boolean)
#4 /src/pocketmine/Server(2222): pocketmine\Server->tick(boolean)
#5 /src/pocketmine/Server(2100): pocketmine\Server->tickProcessor(boolean)
#6 /src/pocketmine/Server(1701): pocketmine\Server->start(boolean)
#7 /src/pocketmine/PocketMine(466): pocketmine\Server->__construct(pocketmine\CompatibleClassLoader object, pocketmine\utils\MainLogger object, string phar:///pro/bin/mcpe/pocketmine-0.13.2/PocketMine-0.13.2.phar/, string /home/gs-40422/, string /home/gs-40422/plugins/)
#8 (1): require_once(string phar:///pro/bin/mcpe/pocketmine-0.13.2/PocketMine-0.13.2.phar/src/pocketmine/PocketMine.php)

Loaded Plugins

NameVersionStateAuthor(s)

Server Settings [toggle]

NameValue
Find duplicates  |   Download